Jump to content

- - - - -

S II dead :(

battery dead recovery mode

  • Please log in to reply
1 reply to this topic

#1 SyNtHeSiS



  • Members
  • Pip
  • 3 posts

Posted 10 November 2012 - 03:08 AM

Hi all. I have a big problem. I placed my phone onto my desk before sleeping (my battery was +/-55%). When I woke up my phone did not want to go on. I tried charging it for 3 hours with my 2 pin charger and it still didn't want to come on (the charging battery animation didn't even show). I also tried charging with the USB cable via PC but that didn't help. I used my multi-meter to check if the battery was working and it showed that it contains +/-3.4V (battery is rated 3.5V). I tried to boot up into recovery mode (volume down + home button + power button) but it still didn't come on Posted Image

I bought my phone at the beginning of the year (brand new) and it has been working with no problems until today. I have essential data on my phone (phone book, messages, apps etc) which are really important and I wouldn't want to lose them. Help would be much appreciated.

#2 chomsky101


    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • LocationGermany

Posted 17 December 2012 - 06:03 AM

have you tried "odin" ?