Jump to content
Android Forum - A Community For Android Users and Enthusiasts

How to reflash a tablet (Onda V712) that won't boot or go into recovery mode?


Recommended Posts

Hello all


I have a peculiar problem with my Onda V712. I'm hoping that you guys may be able to help me out.


The tablet was working fine and was 90% charged. I was having some issues with my google account so I decided to delete it and set it up again. After deleting the google account I switched off the tablet. When I switched it on again a white android bot came on the screen and nothing beyond that. I waited for almost 30 minutes but there was no progress. The tablet wouldn't boot up beyond the white android bot. I rebooted it several times but no luck. I have tried the following so far-


1. let the battery drain completely by leaving it switched on. The white android bot was on all the time. Then I charged the tablet for 6 hours and tried to boot but the issue persists.

2. Tried the reset button several times with no luck.

3. Tried to get into recovery mode by holding the home button and then pressing/tapping the power button. The tablet doesn't go into recovery. It just shows the white android bot and there is no progress after that.

4. Downloaded the latest firmware from the onda site (I have version 2 so I downloaded the appropriate firmware). Unzipped the contents of the zipped file (total 5 files after deleting the instructions file) to a formatted sd card. Inserted the sd card onto the tablet while the tablet was switched off. Then tried to boot via the sd card by pressing the home button and then the power button as suggested in the onda manual (which was in chinese). But it would just power up with the white android bot and wouldn't do anything beyond that.


I am not sure what I can do to revive this tablet. BTW, when I connect the charger to the tablet I can see the animated battery indicator showing that the battery is charging. Also when I connect it to my pc, it shows up as m3-chip in the device manager with an exclamation mark against it. It says that the drivers are not installed correctly or something like that.


Any help would be appreciated. Thanks in advance.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...