Jump to content
Android Forum - A Community For Android Users and Enthusiasts

No SD card inserted


Recommended Posts



Yesterday I got my phone used very much and battery gone to 0%, it turned off. Then I tried to turn it on few times, but still Low battery (was waiting for important call)


Today I noticed, that my phone does not detects extrenal SD card. Tried restarting, tried factory reset, tried different file systems, nothing works (card is working on my pc very well)


When I insert that card, nothing happens. No even a notification or little freeze. Its like I am inserting piece of paper in SD slot (of course i am not doing that, just to compare).


What should I do? Phone is never rooted and running official ICS 4.0.3. which i got on december 2012 over OTA update.


There is warranty, but isnt there a faster workaround without voiding it?

Its my birthday (18) tomorrow and i need my phone at home, not in service for two weeks.


Internal storage works well. But it is too small.. Extrenal is inserted but cant be mounted even by settings button, its grey and cant be clicked. [screenshot]


Huawei Ascend G300.


Thanks for help!


  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...