Jump to content
Android Forum - A Community For Android Users and Enthusiasts

Mobile data seems to be connected but doesn't work


Recommended Posts

Hello, I am encounting a mysterious problem:


Sometimes, the mobile data connection seems to be connected (the arrows are coloured) but the connection doesn't work.
I can't find a rule about a specific factor that causes this malfunction.


I tried to solve the problem by:

  • disabling and re-enabling data connection
  • enabling and re-disabling flight mode
  • using some applications from google play which promises to fix data connection issues
  • cache cleaning
  • ram cleaning



However, I discovered another solution that permanently solves the problem for specific apps:

  • When the problem occurs, I open an application that needs internet connection.
  • I test data internet connection through this application to be ensured that it doesn't work.
  • I disable data connection, enable wifi and test if the application now has internet connection through wifi.
  • I disable wifi connection, re-enable data connection and test again if the application now has internet connection through data connection.
  • Data connection now works normally only for the specific application but not for other applications. Doing the same steps for another application the problem can be also solved for the other specific application.



After these attempts I wonder:

  • Which factor causes the problem?
  • What exactly a reboot achieves that solves the malfunction?
  • How can I solve the problem by acting similarly to a reboot but without rebooting the device?

Any ideas??

Device: Motorola Atrix 4G
Custom Rom: Android 2.3.7 Cyanogenmod MROM -1-0.20130113-olympus


Link to comment
Share on other sites

Thank you for your response.

I have asked many users of my ROM if they have the same problem and none had it.

well, this might be device specific problem. I mean have you asked the users using the handset Motorola Atrix and Cynogen mode ??? if yes, then i guess there might be problem somewhere else.... :(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...