Jump to content
Android Forum - A Community For Android Users and Enthusiasts

ALPS MT6517 iPhone 5 clone USB installation


Recommended Posts

Hi guys, I have an iPhone 5 clone which I cannot connect to my pc. (Win 7 64/32 bit) When I plugged it in, it detects as "Unknown Device" in USB controllers category in Device Manager. I've tried a bunch of MTK 65xx drivers, ADB drivers, Install from disk (.inf file), even tried Pda.Net but still can't install the usb drivers.


I've also tried to power it off then press Volume + then plugged it. (SD card removed, battery cannot remove because it's soldered) It detects as MTK USB Port but it never detects as MTK 65xx Preloader as to what I've searched.


I am so frustrated and I really really want to connect this to my pc so I can start flashing on it.

I hope you can help me with this guys.


model: MT6517

board: sanstar15_2006_p5_gb2

manufacturer: ALPS

CPU: ARM Cortex-A9

RAM: 233 MB

hardware: MT6575

Android Version: 4.1.2 (but I can tell it's Gingerbread)

Kernel Arch: armv71

Kernel Version:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...