Jump to content
Android Forum - A Community For Android Users and Enthusiasts

SDK [Install_Failed_Dexopt] any help?


Recommended Posts

Hello all :)
I am having some trouble with SDK installing apps to my Android. I've tried to find many forums about my issue, but I've hit a brick wall every time. My rooted device is an LG Optimus C running Android 2.2 (ancient lol). My issue is that I'm getting the error: Failure [iNSTALL_FAILED_DEXOPT] for every app I try to install. I've wiped the device twice and then found out that this error happens every time after I've installed a good amount of apps...which I read somewhere that this will happen because of not having enough space in Dalvik..or in the data area and won't allow the install to write anything else..correct me if I'm wrong on this. I've also cleared all caches multiple times, including Dalvik.

I've also tried the work around where you try and skip that all together and put the app straight into /system /app. That came up with no resolution, even with the correct properties selected (read/write/execute etc). So now, I really have no other avenues left but to come here and ask. 

Here is the Logcat results I get using adb install -r app.apk no matter what app it is. I will use tumblog.apk (compatible with device) for this example:

D/AndroidRuntime( 4201):
D/AndroidRuntime( 4201): >>>>>> AndroidRuntime START com.android.internal.os.RuntimeInit
I/AndroidRuntime( 4201): Heap size: -Xmx32m
D/AndroidRuntime( 4201): CheckJNI is OFF
D/AndroidRuntime( 4201): Calling main entry com.android.commands.pm.Pm
W/ActivityManager( 1356): No content provider found for:
W/ActivityManager( 1356): No content provider found for:
D/PackageParser( 1356): Scanning package: /data/app/vmdl-166230949.tmp
D/PackageManager( 1356): Scanning package com.luckydroid.tumblelog
E/PackageManager( 1356): Package com.luckydroid.tumblelog has mismatched uid: 10060 on disk, 10061 in settings
I/PackageManager( 1356): Linking native library dir for /data/app/com.luckydroid.tumblelog-1.apk
D/installd( 1256): DexInv: --- BEGIN '/data/app/com.luckydroid.tumblelog-1.apk'---
D/dalvikvm( 4211): Zip inflate: partial write (will retry): (24536 of 32768)
E/dalvikvm( 4211): Zip inflate: write failed: No space left on device
W/dalvikvm( 4211): DexOptZ: extraction of classes.dex from /data/app/com.luckydroid.tumblelog-1.apk failed
W/installd( 1256): DexInv: --- END '/data/app/com.luckydroid.tumblelog-1.apk' --- status=0xff00, process failed
E/installd( 1256): dexopt failed on '/data/dalvik-cache/[email protected]@com.luckydroid.tumblelog-1.apk@classes.dex' res = 65280
W/PackageManager( 1356): Package couldn't be installed in /data/app/com.luckydroid.tumblelog-1.apk
D/AndroidRuntime( 4201): Shutting down VM
I/AndroidRuntime( 4201): NOTE: attach of thread 'Binder Thread #3' failed
D/jdwp ( 4201): adbd disconnected

I really have no clue what any of this means lol...pretty new to logcat. I am aware of the file name not matching the original name of the apk..shouldn't matter considering I've installed many apps with shortened names. Any help would be greatly appreciated! Thanks :)

EDIT: Looks like "E/dalvikvm( 4211): Zip inflate: write failed: No space left on device" is the problem in dalvik. Still don't know how to get around this problem though.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...