Jump to content
Android Forum - A Community For Android Users and Enthusiasts

Need to upgrade Android help.


neon4
 Share

Recommended Posts

Hello,

I'm planning on buying a smartwatch, I'm definately going for one of the Samsung Gears, mainly because I want to use it for phone calls (as well as for other functions it offers ofc), most likely the Gear S, which will come out soon.

However, my phone is Samsung Galaxy S2 and I have a stock version of Android 4.1.2 and all the smartwatches require at least 4.3+ and there is no newer version for my phone :(

I'm a beginner when it comes to fiddling with android, I know there are a lot of custom firmwares out there with newer Android versions, but I have never been into unofficial versions.

That's why I'm asking for help here.

What version of custom android would be the most suitable for me and how to correctly flash it to my phone.

1.) It has to be 4.3+

2.) It would be great if it looked like the official android version for Samsung phones, something like S4-S5 style, including touchwiz, I know that a lot of people hate it, but it fits me perfectly.

3.) I want it to be the most stable one, to have working stuff. I'm an undemanding user, I'm not really into fiddling with system stuff, doing benchmarks or using any other kind of special advanced apps. I just want it to use it the normal way like with the stock version.

 

I used to install stock versions from samsung via download mode and odin, so I have a little experience with this, but mostly forgotten now.

Buying a newer phone is not an option.

 

Phone info:

Screenshot_2014-09-27-15-34-58_zpsf49ca7

 

Thanks in advance for any help.

Link to comment
Share on other sites

Nevermind...

After hours spent on the internet and educating myself I got myself CM11, snapshot M10, Kitkat version 4.4.4

I'll post here what I did to achieve what I exactly wanted, hopefully someone will find it useful later.

 

(I'm not to be held responsible for any problems you got yourselves into, perform any of the following action only at your own risk)

 

1.) Root the device with appropriate kernel, I used the Siyah kernel with Odin -> http://d-h.st/hcS

2.) Download the CWM recovery to version that supports installation of Kitkat ROMs -> http://forum.xda-developers.com/galaxy-s2/general/cwm-kit-kat-compatible-t2546597

3.) Download i9100 CM11 flashable zip -> http://downloadandroidrom.com/file/GalaxyS2/roms/CM11/cm-11-20140618-NIGHTLY-i9100.zip

4.) Download micro Gapps -> http://downloadandroidrom.com/file/gapps/PA/pa_gapps-modular-micro-4.4.3-20140608-signed.zip

5.) Put the CWM recovery, CM11 and Micro Gapps to your phone memory, can be both SD card or internal storage

6.) Boot to CWM recovery -> find the CWM update and install it -> go to advanced and reboot CWM

7.) Wipe data etc -> find CM11 and install it

8.) Install Gapps -> reboot phone

10.) Go to settings -> phone info -> Cyanogenmod update -> update to newer/more stable version

11.) Install Samsung Galaxy S5 theme (settings -> theme -> more themes -> download)

12.) Install Galaxy Launcher -> https://play.google.com/store/apps/details?id=com.epic.launcher.tw

13.) Install (optional) Galaxy Locker -> -> https://play.google.com/store/apps/details?id=com.lockscreen.galaxy

 

For more reference:

XDA thread that helped me a lot -> http://forum.xda-developers.com/galaxy-s2/help/rooted-siyah-to-install-cm-t2862785

Link to comment
Share on other sites

  • 2 weeks later...

Well @neon4 I am going to answer your question in the same way i.e for getting 4.3+ version of Android over your device you need to head over to the custom ROM like Cyanogenmod, Slim bean, snapshot .... etc.as I don't think samsung is going to upgrade it further I have been hearing that S2 device are lined up for 4.3 Jellybean I wonder why it haven't showed up for you but yes, for trying the gears out I would say the best option would be going forward with the custom ROMs and I don't think I need to guide you with the flashing process as you are already on the right track.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...