Jump to content
Android Forum - A Community For Android Users and Enthusiasts
tds

Cannot delete contacts from SIM card

Recommended Posts

I cannot remove contacts from SIM card on my android Samsung S5.

I have done the obvious.

I have downloaded many of the CONTACT CLEANER apps. None of them worked.

I even reformatted the SIM card and reset the phone. Amazing - they were still there. !!! %$#$

 

Looking at these contacts I see something in common. . . 

- seems they all have email address, no name and no phone number. (this is actually my wife's phone). 

 

I know I can simply ignore them (by not selecting the SIM card in the display). I do have other accounts so this will not work. 

 

Any help would be much appreciated.

 

tds

Share this post


Link to post
Share on other sites

Well, I would say that's not over your sim card rather than its coming from your Google account or some other like if you are using LinkedIN and while setting up LinkedIN it ask to sync LinkedIN contacts with your device, and because you have allowed the permission to sync and which is the reason why those contacts keep appearing over the device ! In order to get out of the trouble better option to check the apps let me know do you use facebook, LinkedIN or any other apps.... !   

Share this post


Link to post
Share on other sites

Your are right John. 

I put the phone in Airplane mode. Deleted the SIM contacts. All good.

Then out Airplane mode on and they contacts on the SIM card were restored. 

 

It surprised me to see these contacts back given that I have no obvious sync to other accounts. Just Google. 

Of course there is that messy ATT stuff in the background which may be causing the issue. I poked around there - looks like the ATT account is not active but one cannot be sure. That seems really messy (read many threads on this topic). I was tempted to root the phone and kill all that stuff but decided not to. 

 

Instead, selected the option to only show Google contacts and live with the nonsense on the SIM card. Its invisible. Having said that, it still bugs the geek in me. 

 

Duncan

  • Like 1

Share this post


Link to post
Share on other sites

Well, the alternative of showing only the Google Contacts is just good ! But yes it it's a bug at all, if you could let me know from where this contacts are sync from then we can turn the sync of for that specific ........ and those contacts will not be shown if you find out which account its coming from then turn the sync for that account over settings>accounts and sync option. Also I wouldn't advise to root your device to get par from this little trouble especially if you are still covered under warranty ! 

Share this post


Link to post
Share on other sites

When I go to contact settings, I have a number of Accounts. 

When I select each in turn, I get

Facebook --> empty (as expected as I turned sync off)

Google --> all my contacts as expected

Device --> empty (as expected)

SIM --> old garbage contacts (the ones I want to delete and cannot)

LinkedIn --> empty (as expected as I turned sync off)

 

Bugs me 

Share this post


Link to post
Share on other sites

Okay, try removing the SIM card out of your device and then put it in some other old device I am sure you must be having a spare old device (I would prefer old Nokia or samsung devices not running android but if you don't have then don't worry) put the SIM card and try removing all the contacts in the SIM card once done again try putting the SIM card back in S5 and see if it appears again or ???  

Share this post


Link to post
Share on other sites

Im reluctant to mess with the SIM card at this stage as Ive finally got my phone set up perfectly (well almost).

But I also believe there is some sync with ATT or something. Since I can delete these contacts in airplane mode. And they come back when the airplane mode is back on.

 

So, I dont believe this is a SIM issue. . . 

Share this post


Link to post
Share on other sites

Well, in that case I don't think I can guide you much further ! Sorry mate I guess you may need to live with this problem a little more while !  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×