Jump to content
Android Forum - A Community For Android Users and Enthusiasts

Android 4.4.2 play store won't launch

Recommended Posts

Bought a galaxy pro12.2 which does not have play store installed.

downloaded .apk file and successfully installed it.

Tab play store icon, won't open.

Anyone has an idea about it?

Tried reset tablet, three .apk file from three sources. No luck.


Tried to download from internet but most app won't download saying the "there is no device".

Please help

Link to comment
Share on other sites

  • 2 weeks later...

Did you purchase the new handset and it's not rooted ??


As i think every android phone have inbuilt Play store. In your case Trying to firstly format your cellphone then see if play store is installed or not.

If yes so it would be good if not so return the cellphone back.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...