Jump to content


Photo
- - - - -

Need help updating Nexus 7 bootloader from version 3.24 to 4.23

nexus 7 bootloader update android

  • Please log in to reply
No replies to this topic

#1 chingondomino

chingondomino

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 07 June 2015 - 01:29 AM

Wondering if anyone can help me with a particular Nexus 7 problem I have. Apologizes in advance if I sound like a noob. I have searched and searched and am at my wits' end. I can't update the bootloader of my pre-production Nexus 7 (Nakasi Wi-Fi) from version 3.24 to 4.23.

 

When I initially unboxed and turned on the Nexus 7 I had just been given I found out that it's a developer model running Jellybean with bootloader version 3.24.

 

At first tried all of the usual ways of updating the OS. Unfortunately none of the ways I tried, via Android Studio, Minimal ADB and Fastboot, and the Nexus Root Toolkit, worked.

 

checking product...
OKAY [ 0.001s]
checking version-bootloader...
FAILED

Device version-bootloader is '3.24'.
Update requires '4.23'.

 

 

I read that if I edited android-info.txt file to read "require board=grouper require version-bootloader=3.24", I would be able to flash 4.1.2 (http://forums.androidcentral.c.... It worked, and after a few hours of constantly updating OTA I ended up with a *slow* Nexus 7 running 5.1.1.

 

I decided to start over and try to update the bootloader again. I know that in some builds there were some problems with bootloader version 4.23 but what I pulled was the latest off of Android's website (https://developers.google.com/.... That didn't work. I tried to flash it through a terminal. I tried to flash it through the Nexus Root Toolkit. I tried different USB ports 2.0 and 3.0 (which shouldn't matter since I was able to update just the OS initially) and that didn't work.

 

The log in the terminal says:

 

FAILED (remote: (InvalidState))

 

 

The *extremely* small text on the Nexus screen says:

 

ignature mismatch
failed to process command flash bootloader error (ox8)

 

 

I think that if I just update the bootloader version from 3.24 to 4.23 I'll be find. I'll be able to update straight to 5.1.1 and have a cleaner install. Unfortunately I can't find any way of doing so online. Any and all help is appreciated.

 

Thanks!







Also tagged with one or more of these keywords: nexus 7, bootloader, update, android