Jump to content
Android Forum - A Community For Android Users and Enthusiasts
Sign in to follow this  
redradist

Android Duplicate files

Recommended Posts

Hello everyone,

I have faced with the issue:

Error:Execution failed for task ':app:transformResourcesWithMergeJavaResForDebug'.
> com.android.build.api.transform.TransformException: com.android.builder.packaging.DuplicateFileException: Duplicate files copied in APK org/apache/http/version.properties
      File1: /my_path/.gradle/caches/modules-2/files-2.1/org.apache.httpcomponents/httpcore/4.4.1/f5aa318bda4c6c8d688c9d00b90681dcd82ce636/httpcore-4.4.1.jar
      File2: /my_path/.gradle/caches/modules-2/files-2.1/com.atlassian.httpclient/atlassian-httpclient-plugin/0.23.0/4c7a2c52647a4f04b39cfcedbe20e3189318033c/atlassian-httpclient-plugin-0.23.0.jar

After this I have figured out that it is because of one file in different jar-files that to be tried to put in one APK
After this I have made the following:

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    compile 'com.android.support:appcompat-v7:25.3.1'
    compile 'com.android.support.constraint:constraint-layout:1.0.2'
    compile 'com.android.support:design:25.3.1'
    testCompile 'junit:junit:4.12'
    compile 'com.google.android.gms:play-services-maps:10.2.1'
    compile 'com.google.android.gms:play-services-ads:10.2.1'

    compile 'com.atlassian.fugue:fugue:2.6.1' {
        exclude 'org/apache/http/version.properties' //     }
    compile 'org.slf4j:slf4j-simple:1.6.4'
    compile 'com.atlassian.jira:jira-rest-java-client-api:4.0.0' {
        exclude 'org/apache/http/version.properties' //     }
    compile 'com.atlassian.jira:jira-rest-java-client-core:4.0.0' {
        exclude 'org/apache/http/version.properties' //     }
}

The following error appears:

Error:(50, 0) Could not find method com.atlassian.fugue:fugue:2.6.1() for arguments [[email protected]] on object of type org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.
Open File

With this error I have stuck ... Does anybody know how to fix it ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...